ФРЕЙМВОРК
 JOOMLA! 3.4+

Запустить урок #2

Официальный сайт Gantry 5

Фреймворк Gantry 5 развивается такими сумасшедшими темпами, что видео созданное буквально пару месяцев назад, уже успело устареть. В частности, теперь есть возможность сразу установить все в одном пакете, а не поэтапно. То есть, нет необходимости сначала установливать Джумлу, затем фреймворк Гэнтри и наконец - шаблон.

Итак, переходим на сайт Gantry.org, где ранее предлагалось скачать сам фреймворк Gantry 5 и сопутствующие ему шаблоны: Helium Theme и Hydrogen Theme.

Теперь появился новый шаблон - Helium RocketLauncher, который в одном пакете (архиве) включает в себя последние версии Joomla, Gantry 5 и Helium, что позволяет все установить по принципу шаблонов QuickStart (быстрый старт).

Официальный сайт Gantry 5

В данному курсе будет рассматриваться фреймворк в паре с шаблоном Hydrogen, который немного проще Helium, хотя они работают одинаково.


Установка фреймворка Gantry 5 и шаблона Hydrogen

Скачайте вышеуказанного сайта фреймворк и шаблон Hydrogen, которые устанавливаются стандартным способом, через "Менеджер расширений".

Если вы не работали с сайтом под управлением CMS Joomla!, то в помощь вам будет два бесплатных курса:

При установке фреймворка может появиться следующее сообщение:

Официальный сайт Gantry 5

Это значит, что архив большого объема, свыше 2 Мб. В таком случае необходимо разархивировать установочный файл в папку tmp, которая находится в корневом каталоге сайта.

После чего, находясь в "Менеджере расширений: Установка", необходимо перейти на вкладку "Установить из каталога", где по умолчанию прописан путь к вышеуказанной папке tmp.

Официальный сайт Gantry 5

Установив фреймворк, перейдите на вкладку "Загрузить файл пакета" и инсталлируйте шаблон Hydrogen.

Чтобы вывести демо данные шаблона Hydrogen на главную страницу сайта, нажмите кнопку "Install Sample Data".

Официальный сайт Gantry 5

В результате при открытии сайта будет следующая картинка:

Официальный сайт Gantry 5

Системные требования использования фреймворка Gantry 5

Во-первых, версия Joomla! должна быть не ниже 3.4.

Во-вторых, версия PHP не менее 5.4 (желательно - 5.5 и выше) и ее выбор производится на хостинге. В случае работы на локальном сервере, изменения производятся в настройках программы или скачайте последнюю версию софта.

Официальный сайт Gantry 5

Если вам необходимо перенести сайт с локального сервера на хостинг, ознакомьтесь с курсом Перенос сайта на хостинг.

 

Добавить комментарий

Защитный код Обновить

Если заметили ошибку, выделите фрагмент текста и нажмите Ctrl+Enter